Microsoft MFA Enforcement

Incident Report for Etail Solutions

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 08:33 CST

Update

All issues are resolved. MFA is now required for EVP RDP. Please log a ticket in the Helpcenter at https://etailsolutionsllc.atlassian.net/servicedesk/customer/user/login?destination=portals for assistance in setting up MFA for your user accounts.
Posted Dec 19, 2025 - 09:59 CST

Update

Action Required - All EVP users must setup and configure MFA to connect to the EVP remote desktop application if you have not done so already.

Please log a User/Password ticket in the HelpCenter for assistance in setting up MFA for your user accounts.
Posted Dec 18, 2025 - 17:26 CST

Update

We are continuing to monitor for any further issues.
Posted Dec 18, 2025 - 12:55 CST

Monitoring

A fix has been implemented and we are monitoring the results. Please log a ticket in the Helpcenter at https://etailsolutionsllc.atlassian.net/servicedesk/customer/user/login?destination=portals for assistance in setting up MFA for your user accounts.
Posted Dec 18, 2025 - 12:54 CST

Identified

We have identified an issue with the Microsoft MFA Authentication system that is now requiring all users to authenticate with an MFA device associated with their account. Each user login will need to register an MFA device with their account so they are prompted for a second authentication method in Microsoft Authenticator.

Please log a ticket in the Helpcenter at https://etailsolutionsllc.atlassian.net/servicedesk/customer/user/login?destination=portals for assistance in setting up MFA for your user accounts.
Posted Dec 18, 2025 - 12:13 CST

Investigating

We are currently experiencing issues with the DNS provider and can confirm in Down Detector that there is a spike in issues. We will monitor the status and update here. Users may experience intermittent issues connecting to the EVP RDP Gateway.
Posted Dec 18, 2025 - 10:04 CST
This incident affected: Core Applications (EVP RDP Application).